Getting Started with Signal Mapper

Jay Bracht -

Registration & Installation (PC)
1. Activate NEON. You will receive an email with the subject line "Welcome to NEON!" from donotreply@trxsystems.com.

  • Click on the "Activate NEON" button. You will be redirected to the NEON activation website.
  • If you have an activation code go to https://neon.trxsystems.com/account/activate
  • Enter your Company Name and activation code and then click the "Activate" button.

2. Create a NEON Account.

  • Enter your email address and a password, then click "Sign Up". 
  • Alternatively, you may click on "Sign in with Google" if you are using a Gmail address.

3. Verify your NEON account. You will receive an email with the subject line "NEON Email Address Verification" from donotreply@trxsystems.com.

  • Click on the "Verify Email Address" button.

4. Log in to your NEON account by clicking on the "Login Now" link or by navigating to https://neon.trxsystems.com

  • You can invite additional users to your NEON Account by clicking on your company name then the "Invite New User" button. 

5. Download the NEON Command software from the "Downloads" tab on the customer portal site.

  • Your web browser may warn you that this file is unsafe.

6. Install NEON Command by following the installation wizard. Click finish to complete the installation.

  • Windows might ask you if you want to allow the installation. If it does, select run anyway.
  • "Start NEON Command" will be selected by default.
  • If the installation is successful the NEON Command window will appear showing the map.

7. Sign in with the NEON account that you just created. 

  • Now you should see your email address in the upper right corner.


Site Planning (PC)
1. Open the NEON Command software and center on the building that you want to map.

  • Click on the search icon located on the top left corner of the map.
  • When a text input box appears, enter the address where you want to map signals. Press enter. 
  • If successful the map will be centered on the given location.
  • Use mouse gestures to zoom and move the map.

2. Create a simple building outline.

  • Click on Tools > Create Building. 
  • Click on the map to set vertices of the building outline.
  • Press enter when done.
  • You now have access to the Building Editor toolbar. You can also right click on the building a select Outline, Floor plan, or Building Tools. 
  • Press the Enter to close the building editor tools when you are finished.

3. Add floors to your building outline. Floors can be added from Right Click > Building > Edit Building Details. 

  • Enter the number of floors above and below ground. 
  • Select a floor height (standard, large) for each floor. 
  • You can set the label of each floor.
  • Click "Ok" to exit the Building Details menu when you are finished. 

4. Add floor plans to your building outline.

  • Select the floor that you want to attach a floor plan to, and then right click and select Floorplan > Add.
  • Select a .png or .jpg image from the file selector. 
  • Right-click on the floor plan then select Floorplan > Edit to access the floor plan editor tools. Alternatively, you can select Floorplan > Edit With Control Points. 
  • Press the Enter key to close the floor plan tools.

5. Click on the Save button then click on "Yes" in the following pop-up to save your changes.

  • The building model will be saved to your NEON account on the cloud.


Installation for NEON Signal Mapper (Android)
1. Open a web browser on the Android device and navigate to: https://neon.trxsystems.com/
2. Log in to your NEON account to access the downloads page.

  • You should see a page with the current version and the previous version available for download. 

3. Download NEON Signal Mapper app by pressing on the "NEON Signal Mapper" button.

  • Your web browser may warn you that this file is unsafe.

4. Install NEON Signal Mapper by clicking on the file from the drop down notification bar.

  • You can also install the app from the downloads folder on the Android device.


On Site Signal Mapping (Android)
1. Open the NEON Signal Mapper app on the Android device.

2. Log in with your NEON account when prompted to sign in.

3. Pair the tracking unit and the Android device. 

  • Turn on the Tracking Unit. 
  • Touch the Tracking Unit to the back of the Android device to pair with NFC Touch Pairing. 
  • Alternatively, navigate to the Location Settings, pair your Tracking Unit through the Bluetooth settings, select your Tracking Unit from the selector in Location Settings, and then enable tracking. 

4. Center on the building that you want to map. 

  • Press the search icon in the top bar. An input text field will appear.
  • Enter the address of the building that you want to map.
  • The building outline created using the NEON Command software should appear on the map.
  • If the building does not appear, press the synchronize button.

5. Select your building by long pressing it.

  • The building outline will turn green and the floor plans will be more visible when you select the building. 

6. Select the floor that you are currently on using the floor selector on the left of the screen.
7. Check-in at your current location.

  • Press the "check-in" icon and then move the map to place the green marker at your actual location.
  • Press the check mark in the upper right corner to complete the check-in.

8. Hold the phone and walk straight at least 10 meters and perform another check-in to get a heading lock.

  • Repeat this step until all location indicators are green and you get the Start Mapping prompt. 

9. Press "Start Now" when you are ready to collect data.

10. Walk through areas where you want to collect data.

  • While you are mapping a timer will be displayed.
  • If any of your location becomes inaccurate, the phone will vibrate and the app will stop collecting signal map data. Check-in until the indicators turn green and the app will resume collecting signal map data.

11. Press the stop icon when you are finished.

12. Press "Upload" and name your signal map file.

  • A cloud icon with an arrow pointing up will appear while the file is uploading to the cloud. If successful, the cloud icon will disappear.
  • The .sigmap file will be saved to the phone's memory at: /phone/NeonSignalMaps 
  • You can retrieve the file manually and then load it into NEON Command from File > Open > File. 


Generate Heat Map (PC)
1. Start the NEON Command application.

2. Select the building.

3. Open a signal map file.

  • Click on File > Open > Cloud Signal Map
  • Select a .sigmap file from the folder created by date, and click "Open".
  • The window "Select Signals" will appear with a list of signals mapped in the log.

4. Generate a signal map by selecting one or several signals that you want to visualize then click the "Generate" button.

  • You may need to switch floors using the floor selector on the right to view the signal maps on that floor.

5. Export the signal map data by clicking on File > Export. 

 

Have more questions? Submit a request

Comments

Powered by Zendesk