Android System Requirements


Recommended System Requirements

  • API Level: 19 or higher
  • Model: Recommended Samsung Galaxy S7
  • OS: Android OS v4.4.2 (KitKat) or later
  • Memory: Recommended 2GB RAM or higher
  • Processor: Recommended Quad Core 1.9 GHz or higher


Recommended Android Devices:

Signal Mapper performance using phones other than listed below cannot be guaranteed.  

  • Samsung S6
  • Samsung S7
  • Samsung S8
  • Nexus 5X
  • Nexus 6P
  • Google Pixel
  • LG G6
  • HTC 10
  • Huawei P10
  • Sonim XP7700 
  • Motorola Lex L10
  • Samsung Galaxy Tab A
  • Samsung Galaxy Tab E
  • Samsung Galaxy Tab 2

* We have found that the Samsung S4 model: GT-I9506 has infrequent Bluetooth connectivity issues with the tracking unit that we have not tracked down yet. 



Was this article helpful?
0 out of 0 found this helpful


Powered by Zendesk